Windows 10 and wake on lan – RedFlagDeals.com Forums

I have three completely different computers that all worked with wake on lan with windows 7 and windows 8. Athlon Phenom II X4 920 on mobo with Realtek RTL81xx network ( from 2009), an i5-2500 (from 2011) on mobo with Realtek RTL81xx network, and an i5-3470(from 2012) on mobo with Intel 82579LM network chip. On all three i disabled hybrid sleep mode with the command line \”powercfg -h off\”. In network driver advanced properties i made sure wol was enabled. In their bios\’ (all completely different) i turned on wake on lan ability. On all three even if i completely shut down i could still wake them up with a Wake-on-lan magic packet. So not just in sleep mode (which also worked) but full shutdown. WOL worked.After upgrading to windows 10 WOL would not work from shutdown. It would work from sleep, but not shutdown. For both motherboards with Realtek drivers i found mention on forums to download the driver directly from realtek instead of using the windows update driver or the motherboard manufacturer\’s driver. I did this and suddenly wake on lan works even from shutdown.But on the last one (Dell optiplex 7010 with i5-3470 and Intel 82579LM network controller) i can\’t make it work. Works in sleep mode but not shutdown. I tried going directly to intel and getting the latest driver. This does indeed add many more options to the driver advance properties window but WOL still won\’t work from full shutdown. Seeing as all three worked before windows 10 and all three had issues with windows 10 i\’m hoping someone else has found another way to fix this. Since the fix with realtek motherboards was to get a specific driver which magically fixed things maybe there is a different driver for intel other than the latest Intel® Network Adapter Driver for Windows® 10 Version: 21.0 (https://downloadcenter.intel.com/downlo … Windows-10) that someone has found that works? Bios is latest (same bios that was working with win7).Any thoughts appreciated.*********UPDATE*********WOOT!So in some more research today i found someone that mentioned re-loading the defaults the the bios after upgrading. I realized i didn\’t do this after upgrading the bios. So i went in and did a Load Defaults and rebooted. Went back in and turned back on WOL (it\’s was moved to off as part of defaults). Now it works. A full shutdown from windows still leaves the NIC alive so that i can send a WOL packet and wake it up.Going to say this just for completeness in case anyone else runs across this thread in the hopes it will solve their problem.Googling WOL problems on windows 8/10 nets lots and lots of messages that include the basic steps.- turn on WOL in your bios- Device Manager -> Your network adapter Properties -> Power Management -> Those three check boxes.- Device Manager -> Your network adapter Properties -> Advanced -> Enable Wake on Magic Packet and Wake on Pattern- Control Panel -> Power Options -> Choose what the Power Buttons Do -> Changes settings that are currently unavailable -> Untick \”Turn on fast startup (recommended)\”The two steps that aren\’t mentioned as often (and ended up solving my problems) are …- For windows 10 go get the new driver from your NIC manufacturer. Not Windows update. Not dell/acer/etc. But directly from Realtek or Intel depending on your particular network chip. There\’s a known issue with the drivers that are installed automatically by windows. Eventually i\’m sure this will no longer be the problem but as of june 2016 it still is with some chips.- if you have updated your motherboard bios, remember to do a \”Load Defaults\” again after the update is done. Even if the settings look correct they may not actually be set correct after an update unless you re load the defaults.Good luck

Yeah there\’s some bug in the driver Windows 10 uses for Realtek chipsets. Even if you make sure they are set to allow WOL, it doesn\’t work. Probably one of the first things I found out about 10. When the machine shuts down or sleeps or whatever it has to tell the NIC to allow WOL I guess and the driver 10 uses by default messes that up and it doesn\’t work. Very strange, but as you indicate if you download the real Realtek drivers it then works fine.Unfortunately I\’m not sure how to help you on the Intel NIC…if you\’ve tried the Intel drivers I don\’t know what to tell you. Can\’t find a solution to that one online?

About the Author

Leave a Reply

Your email address will not be published.

You may also like these