System won\’t boot into BIOS after a possible Windows Update – RedFlagDeals.com Forums

This is interesting…So I went out for dinner, came back and discovered the laptop won\’t boot up anymore(i closed the lid when I left home)I first powered on, waited and waited, but the BIOS screen showed up, and the trackpad and keyboard can\’t control anything(it just displays the BIOS screen and you can\’t change anything). I found that to be weird and just powered off and on againNow it will power up, fans will spin, keyboard black light is on, LED indicators are indicating powered on and flight mode(hum?)But the screen will stay black, won\’t show anything, not a single image.The air from the fan will get a little hot after running for around 2 mins. I have tried pressing Windows+Ctrl+Shift+B which should beep if its booted into Windows but nothing happens when I try it.I have tried connecting to a external monitor but no luck either, as it doesn\’t even boot into Windows I don\’t believe it\’s display\’s problem.I have tried Asus\’s BIOS recovery method which is load the BIOS file onto the USB and plug it in, no luck either.After calling Asus they are asking 80 dollars to check it out and give me a quote of $750 for estimate repair which I believe they think the motherboard is fried.The only possible cause I can think of is I had a prompt for WIndows update before I left home, which I clicked remind me later (or cancel, can\’t remember, but definitely not install now)The laptop is bought in mid 2017 with 7700HQ and 1050Ti if that matters.I am thinking about maybe the RAM failed, which has similar symptoms to this(screen not on, not booting into BIOS)Is there anywhere I can borrow a RAM and test it? I think Bestbuy/Staples/Canada Computers have restock fees or won\’t accept opened boxes at all.Any help is appreciated!

HmMM.. have you tried disconnecting the hard drive? That should eliminate windows from the equation. Remove the hard drive from the laptop and boot off a Windows USB media or something. Or try to do a windows 10 repair with the USB media if it boots with it. I\’d say most likely your machine will have 2 sticks of RAM.. can try removing one and see what happens.

About the Author

Leave a Reply

Your email address will not be published. Required fields are marked *

You may also like these